воскресенье, 24 мая 2009 г.

msvcr71.dll msvcp71.dll

На форуме VMware-Russia

Был у меня тестовый сервер Supermicro с ESXi 3.5 u4

Я на нем ставил вские эксперименты и т.д.

Кроме того на нем было два сервера WIN2003.
И вот решил я поставить на него 4.0, убрать все лишнее и отправить в продакшен.

Скопировал все что было на хранилище, поставил с ноля 4.0 и копирую теперь потихоньку машины обратно и запускаю.

Первый WIN2003 c MSSQL2000 нормально запустился (и SQL тоже) и попросил апдейт vmware tools.

После апдейта, сервер запускается с ошибкой

"At least one service or driver failed system startup/ Use Event Viewer to examine the event log for details."

И SQL сервер не запускается!

При поптыке запустить вручную:

"The service did not respond to the start or control request in timely fashion"

"An error 1053 - (The service did not respond to the start or control request in timely fashion.) occurred while performing this service operationon the MSSQLServer service."

В events две ошибки

"Timeout (30000 milliseconds) waiting for the MSSQLSERVER service to connect."

"The MSSQLSERVER service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion. "

Попробовал заново скопировать vmdk с системным диском.

То-же самое - все ОК, пока не обновил vmware tools.

Что это может быть, и как это побороть?


.......


Исследование показало, что при деинсталяции vmware tools сносит две dllки
msvcr71.dll
msvcp71.dll

Я их обсе сразу после деинсталяции перед перезагрузкой скопировал обратно в %systemroot%\system32
Все ОК.

Гугль говорит что это далеко не первая проблема vmware tools с этими dllками.

1 комментарий:

  1. Вообще говоря, у меня давно есть серьёзные претензии к установщику VMware Tools. Другое дело, что они относятся к недокументированному и неподдерживаемому функционалу, поэтому я об этом никогда никуда не писал :)

    Установщик некорректно создаёт пункт административной установки (о том, что это такое, и зачем используется, я когда-то писал вот тут: http://pronichkin.com/Lists/Posts/Post.aspx?ID=64). Т.е. установка проходит без ошибок, но в действительности копируются не все файлы. В результате такой пункт административной установки оказывается слабо пригоден для использования. Приходится всё-таки один раз запускать штатную установку из полного дистрибутива, а потом копировать файлы вручную.

    К чему это я? К тому, что установщик уже был замечен в раздолбайском отношении к файлам, поэтому описанная тобой проблема меня не удивляет :)

    ОтветитьУдалить