суббота, 23 августа 2008 г.

ESX под VMware Workstation

По поводу запуска ESX под VMware Workstation -
это возможно.

Вот буквально только что я взял:

  • Сервер Fujitsu Siemens TX200 S4, Intel Xeon E5405 .
    в теории, подойдет любой CPU с поддержкой Intel-VT / AMD V.
  • На него установил Win2003.
  • На него установил VMware Workstation 6.5 RC1.
  • Под ней создал ВМ в соответствии с гайдом.
    Основное там -
    тип ОС - Red Hat Enterprise Linux 4 64-bit
    тип контроллера - SCSI LSI Logic
    для процессора ВМ в опции Preferred Mode выбрать - Intel-VTx or AMD-V
    добавить в конфиг строку - monitor_control.restrict_backdoor = “true"
  • В эту ВМ проинсталировал ESX 3.5.
    ESXi, кстати, не завелся.
  • Под ESX в ВМ нормально запусклись и работали ВМ с Win2003.

14 комментариев:

  1. Про ESXi новость плохая. Под 6-й воркстанцией он заводится, поверх и с настройками ESX 3.0.2
    Но запуск виртуалок там его валит

    LevT

    ОтветитьУдалить
  2. Странно, я считал, что у ESX и ESXi одинаковые "пристрастия" к оборудованию. Наверное дело в отсутствии вырезанного "куска редхета". Возможно, в связи с этим имзенены какие-нибудь интерфейсы работы с железом?

    ОтветитьУдалить
  3. по моему, списки совместимости - очень похожи у ESX\ESXi.

    ОтветитьУдалить
  4. ESXi по Workstation 6.5 нормально и саокойно встает и работает

    ОтветитьУдалить
  5. в vmx вносили только стандартные изменения?
    по гайду от ESX?

    ОтветитьУдалить
  6. да или вобще не вносил

    ОтветитьУдалить
  7. кстати ради интереса бесплатный Citrix XenServer тоже установился без проблем под Workstation 6.5.1 (6.5.2), только вот он просит вирт. HDD от 12 Гб

    ОтветитьУдалить
  8. да, только он не дает внутри ВМ запускать.

    Кстати, под Workstation и vSphere заводится - ESX 4 и ESXi4 я заводил, нормально.

    ОтветитьУдалить
  9. любопытно, вот именно до ВМ под цитриксом руки не дошли, надо попробовать
    И где бы скачать vSphere ?

    ОтветитьУдалить
  10. К сожалению, на официальном сайте его не дают.
    Есть мнение, что давать начнут 21 мая - но я точно не знаю.
    уточняю сейчас этот вопрос.

    у меня она есть как у бетатестера - игрался с релиз кандидат версией.

    ОтветитьУдалить
  11. Че-т вместо 21 мая стало чаще звучать Q2 2009, так что хзхз...

    ОтветитьУдалить
  12. Наличие Intel-VT обязательно? Хотел на буке внутри Воркстейшена запустить ESXi3.5 Приглашения к установке не долждался, ооочень медленно запускается.

    ОтветитьУдалить
  13. обязательно.
    кстати, ESX 4 встает под Workstation 7 без дополнительных телодвижений.

    ОтветитьУдалить
  14. Наличие Intel-VT обязательно для любых 64-битных гостевых ОС, и в частности для ESX 4

    ОтветитьУдалить